chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I have the enterprise version and I have installed it on the Build Server.

I am using FinalBuilder and I am having problems getting TMockRunner.exe to work. I have called mocking_on.bat but it didn't work. Are there some other settings before I can do this? I got an error saying Typemock not enabled.

I tried calling: TMockRunner.exe nunit-console.exe "mytests.dll" and it worked from the command line. However FinalBuilder has a run Cmd task and it didn't work from there. Is there some special thing that I have to do? I got an error saying "System unable to find the file"

I tried putting the entire command in a batch file and then calling it from the FinalBuilder task, but that didn't work. I got an error saying "'TMockRunner.exe' is not recognized as an internal or external command,operable program or batch file."

3 different errors :cry:. I think if I can use mocking_on.bat it would be the easiest.
asked by diangy (2.4k points)

4 Answers

0 votes
The next version of FinalBuilder will have an option to run with Typemock
and on top of that we created FinalBuilder task to run with Typemock.
We will send you the FinalBuilder task later
today so you can start using it. :)
answered by ohad (35.4k points)
0 votes
In FinalBuilder, make sure you choose teh "Run Dos Command" task
and then:
under "command" set the TMockRunner.exe as you specified in your post
in the "Start In" field, put the directory location of the TMockRunner.exe file

Please let me know if this works for you.
All the errors seem to indicate that you are not calling the file in the correct location, nothing more.
answered by royo (2k points)
0 votes
Thanks, that worked. I used so many combinations that I forget to use the Start in parameter. I assumed since I had set the path I wouldn't need to use the Start in parameter.

My CI server is finally up. I am using FinalBuilder exclusively as my build server and it works great. I've stopped using CC.NET and Nant.
answered by diangy (2.4k points)
0 votes
I'm glad it worked for you :)
We're using FinalBuilder internally for our build process as well (not exclusively, but we're getting there..)
answered by royo (2k points)