chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
Is the IntelliTest not working with VB.NET? When TypeMock 5.4.3 is installed it is IMPOSSIBLE to write any code. The second letter of every word is put in a parentheses and when trying to backspace Intellitest keeps "fighting back".

Dim becomes D(i)m! String becomes S(t)ring!

This is in Visual Studio 2008 SP1.

See this video for an example.
asked by halstein (8.7k points)

5 Answers

0 votes
I've now tried with 5.4.3, 5.4.2 and 5.4.0 and all have the same problem. I also tried with 5.3.5 and that version does not have this specific problem, but because of the problem with Gallio I still cannot use anything later than 5.3.1.

I should also mention that this is on Windows 7 x64.
answered by halstein (8.7k points)
0 votes

We haven't seen this kind of issue before. IntelliTest does not support VB but it should not interfere with editing. This is a bug. As a workaround you can disable the IntelliTest addin(Tools -> Add-in Manager -> uncheck Typemock Productivity). It will disable IntelliTest and will let you continue working with Isolator as usual.

I'll try to reproduce it here and fix it.

Please let me know if it helps.

Typemock Support
answered by Elisha (12k points)
0 votes
The workaround worked. Disabling TypeMock Productivity got the intellisense in Visual Studio working again for Visual Basic. Sadly, 5.4.3 still doesn´t work with Gallio on x64 Windows, so it is back to 5.3.1 anyway.
answered by halstein (8.7k points)
0 votes
We have experience the same issue without x64, but using VB.NET in VS 2008. the same workaround allowed us to continue working.
answered by tjwalton (720 points)
0 votes
Hi All,

Thanks for your reports, and thanks halstein for the excellent reproduction. We fixed the bug, and I'm sending a patched version to anyone who complained. The fix will be publicly available later this week in a version release. If anyone needs it earlier, please email us at support (at)

Typemock Support
answered by doron (17.2k points)