chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
I've installed Typemock 2010 on a server with VS2010 Beta 2. When I try to run a unit test from within the VS client, I get the TypeMockException that Isolator isn't enabled. I've tried disabling and re-enabling Isolator through the menu, and restarting Visual Studio, but can't get it to work. Is anyone else having issues?

For what it's worth, I am running VS as an administrator.

asked by jturbyfill (640 points)

4 Answers

0 votes

Can you please tell me what test runner are you using? (MSTest, TestDriven.NET etc)
Also what is the OS? Is it 64 bit or 32 bit?
answered by ohad (35.4k points)
0 votes
I'm running against MSTest, on Windows Server 2008 (x64).
answered by jturbyfill (640 points)
0 votes

It maybe an installation problem.
Please try to do clean install:
1. Close all instances of Visual Studio.
2. Uninstall the Isolator.
3. Go to the Isolator addin directory in C:ProgramDataMicrosoftVisualStudio.0Addins
if the files "TypeMock.AddIn2010.AddIn " and "TypeMock.Productivity.AddIn"
exists delete them manually.
4. Install the Isolator.

Let me know if the problem repeats after you tried the process above.
answered by ohad (35.4k points)
0 votes
It is the VS2010 new Intellitrace feature. Very probably you enabled the option: IntelliTrace events and call information. Please change it to IntelliTrace events only and this solves it.
answered by rcrisan (140 points)