chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
Could you please tell whether Silverlight 4 is supported.
I tried to user Typemock with VS2010 and faced with following troubles.

Environment details
PC: Win7 x64
SL: 4.0
VS: 2010

1. I created simple silverlight app.
2. Created test new Test project inside VS.
REmoved all reference except Microsoft.VisualStudio.QualityTools.UnitTestFramework
and added CThru, SilverUnit, Typemock and System.Windows.
3. Created simple unit test.
When I tried to execute it inside VS I got an error related to System.Data.xml which means that isolator is not started. However Typemock isolator is enabled.

And second case.
I tries to use NUnit and everything seems fine. I mean when tests are executed with TMockRunner they are executed properly. But after installing latest NCover and linking it with Typemock Isolator i have the same error about System.xml. I used GUI tool to link typemock and NCover

I would be grateful if you could point me either to my error or manual how to configure Typemock, NCover and silverlight tests.

Thank you.
asked by Unresponsible (680 points)

3 Answers

0 votes
UPD. After restart first problem seems gone. At least test are successfully executed inside visual studio.
But now question regarding Coverage tool with Typemock. After configuring linking tests fail.
answered by Unresponsible (680 points)
0 votes

I'm glad the first issue solved itself. Regarding the coverage tool linking issue, I would like some more information - what version of NCover are you using? what test runner are you using?

Many times this sort of issue is a 64 bit configuration issue - you may be using a 32 bit runner and trying to run 64 bit NCover or vice-versa. We may be able to help with some more information, or take this case offline for further investigation.

Typemock Support
answered by doron (17.2k points)
0 votes
Hi, thank you, but issue has been resolved.
I tried to run 32 bit runner with x64 version of nCover.

Thank you.
answered by Unresponsible (680 points)