chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I'm getting the above error message when building my solution which contains [Isolated] tests. This has started happening after I upgraded the solution from visual studio 2010 to 2012. I have tried enabling the logs, but only empty logs are being created.
Please help, thanks!
asked by Guillaume (3.5k points)

4 Answers

0 votes

1. If the Isolated attribute is removed does the execution succeed?
2. If you start a new unit tests project in VS 2012, does it work correctly?
answered by Elisha (12k points)
0 votes
1. No
2. Yes

answered by Guillaume (3.5k points)
0 votes

I tried to reproduce this issue but it seems to be working on my machine.

1) Which Isolator version do you use?
2) Did you make any changes to the solutionproject as part of the upgrade (.NETIsolator version)?
3) What happens when you create an empty test project in VS2010 , write one test using Isolator, save it and then open it in VS2012?
answered by alex (17k points)
0 votes
I turned off automatic test runner. I didn't realize I could do so by the little code editor tab. This would have been much simpler if the option appeared in the Typemock options menu.
This is no longer a high importance issue. I'll try and get you the info you need, but the lowered priority will lengthen the delay in my replies.

Thanks for your time.
answered by Guillaume (3.5k points)