chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
I need to run 6.1.2 for time being. I was on 7.1.2 and I uninstalled that. Then I installed a copy of 612. I tried rebooting, enabling/disabling isolator, but my unit tests insist that isolator is not enabled.

I also tried disabling intellitrace and that didn't help either. Is there a registry key I need to delete or something?

asked by sorakiu (4.2k points)

3 Answers

0 votes
Here is the full error message when I try to run an isolated unit test now:
Test method ****.UnitTest threw exception:
*** Typemock Isolator is not currently enabled.
To enable do one of the following:

* To run Typemock Isolator as part of an automated process you can:
- run tests via TMockRunner.exe command line tool
- use 'TypeMockStart' tasks for MSBuild or NAnt

* To work with Typemock Isolator inside Visual Studio.NET:
set Tools->Enable Typemock Isolator from within Visual Studio

For more information consult the documentation (see 'Running' topic)
answered by sorakiu (4.2k points)
0 votes

I imagine that by "enabling/disabling isolator" you mean the add-in.
Please open Typemock menu in VS, if the first line says enable mocking - click it.

Let me know if it helps.
answered by alex (17k points)
0 votes
Yes, it is enabled there, but in the test runs, it insists that it is disabled.

Is there anything add'l I can check to get to the root of this problem?

answered by sorakiu (4.2k points)