chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
Hello, I have updated to 7.4.2 and I keep getting a "TestRunner crashed trying to run test" error. Below is more info.

TestRunner Info: Test timed out
TestRunner Error: There was an error reading from the pipe: The pipe has been ended. (109, 0x6d).

Server stack trace:
at System.ServiceModel.Channels.PipeConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
at System.ServiceModel.Channels.DelegatingConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
at System.ServiceModel.Channels.SessionConnectionReader.Receive(TimeSpan timeout)
at System.ServiceModel.Channels.SynchronizedMessageSource.Receive(TimeSpan timeout)
at System.ServiceModel.Channels.TransportDuplexSessionChannel.Receive(TimeSpan timeout)
at System.ServiceModel.Channels.TransportDuplexSessionChannel.TryReceive(TimeSpan timeout, Message& message)
at System.ServiceModel.Dispatcher.DuplexChannelBinder.Request(Message message, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Typemock.Common.Core.ITestRunnerService.RunTests(List`1 assemblies, List`1 testNames, String sessionID, Dictionary`2 testsOptions, List`1 path2TestSettings, String solutionName)
at Typemock.Common.Core.TestRunnerServiceSynched.RunTests(List`1 assemblies, List`1 testNames, String sessionID, Dictionary`2 testsOptions, List`1 path2TestSettings, String solutionName)
at Typemock.Common.Core.DaemonTestsRunner.PerformRunTests(List`1 testsAssemblies, IEnumerable`1 testNames, Guid sessionGuid, Dictionary`2 testOptions, List`1 path2TestSettings)
at Typemock.Common.Core.DaemonTestsRunner.TryPerformTests(List`1 testAssemblies, IEnumerable`1 testNames, Dictionary`2 testsOptions, List`1 path2TestSettings, Guid sessionGuid, ManualResetEvent allTestsFinished)
TestRunner Error: TestRunner crashed trying to run test:
asked by ALMGuy (680 points)

4 Answers

0 votes

Can you please run Typemock Isolator with logs and send the logs to

To enable Typemock logs go to Typemock menu (in vs) -> options -> visual studio tab -> check the logging check box.

Run the tests and the logs will be created on the folder you mentioned in the Typemock options screen.

answered by NofarC (4k points)
0 votes
Hello, I tried to email you a zip file of the logs, however your email system does not accept logs of over 5mb. One file was 8mb. I only ran the unit test ONE time and it produced an 8 mb file.

Please advise.
answered by ALMGuy (680 points)
0 votes
Hi ALMGuy,

Thank you for sending the log files.
This issue looks like one we had in a previous version and should be solved in 7.4.2.

Please uninstall Isolator.
Open C:Users[YOUR USER]LocalMicrosoftVisualStudio[10.0 and 11.0]Extensions and make sure that Typemock folder doesnt exist,
delete it if it's still there.

After you that, reinstall Isolator.

Looking forward to your feedback.
answered by alex (17k points)
0 votes
Hello, so, re-installing your product did NOT work. I tried it 2 different times on 2 different machines. I verified the folder was NOT present after each uninstall. I am installing 7.4.2

This issue is preventing new tests from being written as well as execution of old tests.

Please advise.
answered by ALMGuy (680 points)