chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes


We're running into an issue where we are seeing the following error logged:

TypeMockRegister Error=*** Typemock Isolator Cannot be deployed, following file is required: C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssemblies amespaces.dat C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssemblies ypemockconfig.xml C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssembliesTypeMock.Configuration.exe C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssembliesTypemock.ArrangeActAssert.dll C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssembliesTypemock.Isolator.VisualBasic.dll C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssembliesexclude.dat C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssemblieslacklist.dat C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssembliesMockWeaver.dll C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssembliesProfileLinker.dll C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssembliesdMockWeaver.dll C:UserssvcTFSApplicationAppDataLocalTempBuildAgentAssembliesdProfileLinker.dll

We are setting the AutoDeploy direction in the build template to a project specific location (i.e. using the "Typemock Isolator per Team Project or Branch" model) so we shouldn't need to deploy these assemblies to the TFS custom build activities folder.

This only started to happen when we updated to v8.1.1.11 of TypeMock. Previously, we were on 7.5. After eliminating the obvious things, I decided to decompile the code of the TypeMockRegister task in the TypeMock.TFS2012 assembly. I noticed that the AutoDeployDir property is never forwarded to the TypeMockRegisterInfo class. Here is a screenshot.

Could this be the source of the error??

Thanks in advance,


asked by csantos (2.8k points)
Does anyone at Typemock monitor this list??

2 Answers

+1 vote
Best answer

We fixed this issue in version

Please download the latests version from our website.

Let us know if it helps.

answered by Bar (3.3k points)
selected by csantos
Hi Bar,

Sorry for the late reply but I was out of the office. I just finished testing v8.1.2.6 and it worked. The only change in behavior was that while the previous version didn't require the Typemock.Isolator.VisualBasic.dll to be checked into the AutoDeploy directory (i.e. the project specific folder, not the folder where the TFS activity assemblies are checked in). This isn't a huge deal but we previously never bothered checking it in since we don't use VB.Net. Without checking it in, we received this error:

TypeMockRegister Error=*** Typemock Isolator Cannot be deployed, following file is required:

This isn't a deal breaker though and so v8.1.2.6 addresses our needs.

Thanks for staying on top of this,

–1 vote
We fixed this. It'll be available in the next release. 
We'll update you.
answered by Bar (3.3k points)

Is v8.1.2 the patch? If so, it doesn't appear to work. At first, we just added the assemblies listed in your TFS integration article and got the following error:

Property accessor 'IsAutoDeploy' on object 'TypeMock.TFS2012.TypeMockRegister' threw the following exception: 'Object reference not set to an instance of an object'

Next, we added the entire contents of the AutoDeploy directory and still got the same error.