chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
I'm running into a strange problem. I'm in the process of implementing TypeMock into my existing unit tests so i have a mixture of unit tests that use TypeMock objects and some that don't.

I'm trying to run the tests through TestDriven.Net in visual studio and i'm running into problems. when i run the tests one by one, they all pass. when i try to run a set of tests, some of them fail with the following error:

TestCase 'XXXX' failed: System.NullReferenceException : Object reference not set to an instance of an object.

The tests that fail are the ones that are not using TypeMock but the Object that is coming up null is of a type that is mocked in another unit test.

also, when i run the tests through the NUnit gui, they all pass.

Any ideas?
asked by maird (800 points)

11 Answers

0 votes
Thank you! that did the trick.

Your welcome :-)
answered by scott (32k points)