chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes

We have downloaded a 3.6 upgrade and bought a new license for a build server. Then our problems began. Right now I can use TypeMock on my machine, but if I try to run tests (using TestDriven.NET) on a build server, then as long as TypeMock is enabled nothing happens: after a long waiting time VS prints in output window that 0 tests have run.

I tried to re-enable TypeMock in Visual Studio and stopped test process. Nope. Test server process does not seem to even start as long as TypeMock is enabled.

Here are extracts from TypeMock logs:

File 1 (LinkedProfilers-ProcessInvocation.exe-13.10.2006-12-58-4.out):

Logging program: C:Program FilesTestDriven.NET 2.0ProcessInvocation.exe
Cannot read EnvName0 => The system cannot find the file specified.
Reset Location: C:PROGRA~1NCoverCoverLib.dll
Adding profiler: {6287B5F9-08A1-45E7-9498-B5B2E7B02995}
Loaded C:PROGRA~1NCoverCoverLib.dll
Adding typemock profiler
Loaded C:Program FilesTypeMockTypeMock.NETMockWeaver.dll
Target Runtime .NET 2.0
Initialize Profiler 0, Target Runtime .NET 2.0
Initialize Profiler 1, Target Runtime .NET 2.0

File 2 (TypeMock-ProcessInvocation.exe-13.10.2006-12-58-4.out):

Logging program: C:Program FilesTestDriven.NET 2.0ProcessInvocation.exe
Known namespace: nunit
Known namespace: vstesthost.exe
Known namespace: MbUnit
Known namespace: TestDriven.TestRunner.dll

What can be wrong?
asked by vagif (19.4k points)

6 Answers

0 votes
Well, I eventually managed to make it work after disabling and re-enabling TypeMock and unlinking and then re-linking it with NCover.

But it feels shaky.
answered by vagif (19.4k points)
0 votes

Thanks for sharing this with us.

What Build System are you using?
Are you using the TypeMock MSBuild/NAnt commands?

:idea: The next version of TestDriven will have a better integration and will do the linking for you when running NCover.
:idea: We will also release a patch that will make this smoother.
:arrow: Until we release our next patch release it is better to Disable TypeMock and restart the Rocket, when running NCover Tests.
answered by scott (32k points)
0 votes

On our development machines we are using TypeMock with Visual Studio 2005 (UI environment). Build machine typically runs TypeMock via command-line (MsBuild), but sometimes I validate some projects using VS environment. What I've discovered is that TypeMock is very sensitive to any configuration changes, including:

- Change of license type (from evalution to enterprise);
- Linking to a coverage tool;
- Version upgrade.

Usually any configuration change results in build server reporting zillions of unit test failures. Then I have to fix it manually, and I have not yet formalized the steps: it's a trial and failure process.
answered by vagif (19.4k points)
0 votes
It shouldn't be so.
- Change of license type should not be any problem.
- Version Upgrades require a rebuild, a message should apear with this warning
- Linkages can be tricky, we are working on that area to make it a much smoother process.

We are going to retry all the scenarios you wrote to validate some problems that you wrote. if possible could you give us a more detailed account (either here on the forums or via e-mail), this will help us create an even better product.
answered by scott (32k points)
0 votes

Right now it works. and I am afraid to touch it :D

If it happens again, I will repoduce all steps and send it to you with all details.

Thanks for the feedback.

answered by vagif (19.4k points)
0 votes
Fine 8)
If anyone else experiances these problems please post a note
answered by scott (32k points)