chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I've set up a test or two that work fine and pass when run in Visual Studio, but when run in MightyMoose ( then fail deep inside Isolator. Following is an example failure:


*** No method calls found in recording block. Please check:
* Are you trying to fake a field instead of a property?
* Are you are trying to fake an unsupported mscorlib type? See supported types here:

Stack trace
at gr.a(cv A_0, Boolean A_1) in
at dj.a(Boolean A_0) in
at do.b(Boolean A_0) in
at iz.b(Boolean A_0) in
at iz.a(Object A_0, Boolean A_1, Func`1 A_2, Action A_3, Action A_4, Action A_5) in
at iz.b(Object A_0) in
at TypeMock.ArrangeActAssert.ExpectationEngine`1.a(TResult A_0) in

MightyMoose is using the Profiler API to gather metrics. I've tried editing typemockconfig.xml to register the profiler and ran TypeMock config to "link" that profiler; but get the same error.
asked by peterritchie (1.2k points)

4 Answers

0 votes
Currently we do not support MightMoose.

We will have to investigate this further.

Can you post back the entry you wrote in typemockconfig.xml?
answered by yoel (1.9k points)
0 votes
Hi Yoel.

Here is the entry I added to the config file:


Thanks -- Peter
answered by peterritchie (1.2k points)
0 votes
Okay, I guess the forum edit trashed the contents of the XML elements. Let's try again:

<Profiler Name="MightyMoose" Clsid="{5D789D88-EEE7-46C4-909F-E39D5606544D}" DirectLaunch="false">
<EnvironmentList />
answered by peterritchie (1.2k points)
0 votes
Hi Peter,

It seems that you got the wrong CLSID value :)
Replace the CLSID to this value: {36C8D782-F697-45C4-856A-92D05C061A39}
and make sure you are linked before the tests run.

Please let me know the results.
answered by ohad (35.4k points)