chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
Hello

We have a large solution with many NUnit tests using Typemock 5.1.1.0. As Typemock is making it very hard to upgrade to a new version we are stuck using exactly this version. In Visual Studio we are using Resharper and running the NUnit tests with the integrated Resharper functionality. This has worked nicely with VS2008 and Resharper 5 but since we upgraded to VS2010 using Resharper 6.0.2202.688 Typemock is no longer loaded when the NUnit tests are run. As I understand this is an incompatibility between the (old) Typemock version and either VS2010 or Resharper 6.

For this reason we are currently using the NUnit GUI to run our tests. The GUI is launched using TMockRunner.exe so Typemock is loaded correctly. This scenario does work but is much less confortable than using the built in Resharper functionality.

Because of that I would like to know if there is any workaround to integrate TypeMock 5 into Resharper 6 / VS2010? I was hoping that I could activate Typemock in the FixtureSetup method or link it somehow as it was automatically done in VS2008 and Resharper 5. Is there a way to achieve this? Any other ideas?

Info: I also posted this topic at the Resharper forum.

Thx & kind regards
asked by amelie (3.1k points)

3 Answers

0 votes
Hi,


Do you think it would be a good idea to schedule a call to find out how we can assist?
answered by yoel (1.9k points)
0 votes
I think the problem is pretty clear and easy to reproduce - but if you think this is the most efficient way to find a solution, sure. I can offer a Teamviewer session if that helps.
answered by amelie (3.1k points)
0 votes
Hi,

I sent you mail from our support mailbox to set up the meeting.
answered by ohad (35.4k points)
...