chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I have just done a new clean install of Windows 8 and VS2012 on my development PC. After installing Typemock 7.1.5 I cannot run any tests within the VS2012 Test Explorer (I am using the Typemock provided C# sample application). I get the error

------ Run test started ------
Exception has been thrown by the target of an invocation.
========== Run test finished: 0 run (0:00:05.2558535) ==========

I installed VS2010 in the same PC and opened the same project, all the test runs OK, so it is an issue with VS2012 and Isolator

If I disable Isolator mocking (using another sample solution that contains tests that use Isolator and some that do not) the test run and pass other than then isolator based ones 9as expected). However, I then enable mocking ALL the test fail to run with either the same error as shown above, or just appears to hang waiting for something.

This would appear to be similar to https://www.typemock.com/answers/11400/?show=17895#a17895 but I have am running 7.1.15 which is mean to have the correct namespace file. I have also checked the contents and it seems Ok

Any suggestions?
asked by rfennell (6.8k points)

10 Answers

0 votes
Further information - having Typemock mocking enabled stops ALL tests running in VS2012 test explorer, just tried another demo project that has not references to Isolator at all
answered by rfennell (6.8k points)
0 votes
Hi Richard,

We are going need some more details ( Isolator and visual studio logs ).

Also which VS do you use (Ultimate \ pro..)?

Looking forward to your answer.
answered by alex (18k points)
0 votes
I am running VS2012 Ultimate, which logs do you need and how shall I send them to you?

I tried to attach the typemock logs but they are too large
answered by rfennell (6.8k points)
0 votes
Hi,

Just sent you a link to google drive where you can upload the files.

in addition to typemock logs I can also use VS logs.

To generate VS logs run devenv.exe \log in the cmd.

Please let me know when you upload the files.
answered by alex (18k points)
0 votes
Hi,

We are still working on it.
Will post here the solution when we are done.
answered by alex (18k points)
0 votes
Hi Richard,


Attached here is the patch that should fix the Win8\VS2012 issue.

*VS 2012 Coverage still doesn't work and a suitable patch will be released soon.


Please let me know if it works.
answered by alex (18k points)
0 votes
Is this patch available? I am unable to run my test on my VS2012 Update 1 + Win8 boxes, but can run them on VS2012 Update 1 + Win 7Sp1.

I'm using Isolator V7.1.6

I also have the same issue on Server 2012 as well.

Stephen
answered by swoolhead (1.2k points)
0 votes
Hi Stephen,

Typemock's R&D has been focused on this issue for the last few weeks.

The solution should be offered in the next release which should be soon.

I'll keep you posted.
answered by alex (18k points)
0 votes
Hi Stephen,

Can you please try installing this patch?

Looking forward to your replay!
answered by NofarC (4k points)
0 votes
Hi Stephen & Richard,

I'm glad to inform you that our new version of Typemock Isolator is out and available here.

It would be great if you'll try it and give us a feedback about the issues you brought up.

Looking forward to your response,
answered by NofarC (4k points)
...