chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
HI,

I do experience two utmost strange issues:

1) After installing TypeMock 7.1.2 it does not show up at the 'TOOLS' menue!

2) When trying to run a test the test fails with the cause 'TypeMock is not enabled'.

The hint to enable it in 'TOOLS/Enable...' fails since he menu entry does not exist.

I run a Windows 7 & VS 2012.

Can you give me some advise how to cure that?

Thank you!
asked by mph (6k points)

17 Answers

0 votes
Hi Alex,

No, it did not help.

Peter
answered by mph (6k points)
0 votes
Hi Peter,

Thank you for the feedback.
We will keep working on it and offer a new solution soon.
answered by alex (18k points)
0 votes
Hi Peter,

We haven't been able to reproduce this issue locally nor get enough info to fix it
so we've made a patch that should give us the info we need.

You can download the patch here.

Please install this patch, run the tests and send us the new error message.
answered by alex (18k points)
0 votes
Downloaded the patch, installed it -> no change. Same error message.

Peter
answered by mph (6k points)
0 votes
Sorry, I forgot to post the error message.
TypeMock 01.PNG
answered by mph (6k points)
0 votes
Hi Peter,

Thank you for the feedback.
We will keep working on it..
answered by alex (18k points)
0 votes
Hi Peter,

Please try the patch attached here, and let us know if it helped.
answered by NofarC (4k points)
...