chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
Upgraded to isolator

Windows 7 Ultimate
Using visual studio 2012

Upon starting a VS unit test we now got:
Common Language Runtime detected an invalid program.
asked by bluelaurend (600 points)

2 Answers

0 votes
I have the same error after installing Windows security updates for the .Net framework (KB2742595).
- When removing KB2742595 the test runs.
- When installing KB2742595 and I disable the TypeMock add-in and extensions in VS the test runs.

I tried to add System or System.Uri to the blacklist.dat file but that didn't help.

The error also occurs when the test isn't using Typemock.

Typemock 7.1.7
Windows 2003 SP2
Using Visual Studio 2010 and VS2012 is not installed.
answered by Jesse (260 points)
0 votes
The same issue is described in the Isolator bugs section:
answered by Jesse (260 points)