chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
We're currently in the process of upgrading our targeted framework to the newer 4.5 and it's dot releases.
When our projects target .NET 4.0, we have no issues with running our unit tests in a 3rd party runner (Resharper's Unit Test Explorer). However, when we upgrade them to target .NET 4.5 and above, we can no longer use our 3rd party runner to run tests using Typemock Isolator. The error message provided is that Isolator is currently not running, despite the check box for mocking 3rd party runners being checked.

The Typemock Smartrunner is capable of running these tests, and our unit tests complete as normal when run in that manner, however, we are not interested in using the Smartrunner, and would prefer to have it disabled completely. It makes no difference for our 3rd party tool if the Smartrunner is enabled. I have also attempted to reinstall Typemock, but that didn't help either.

Is this a known issue, and are there any workarounds for this?

Thanks!
Thomas
asked by thni (3.2k points)

6 Answers

0 votes
Hi,

I tried reproducing this issue with Isolator 7.5 and Resharper 8.2 and works fine.
Are you able to reproduce this issue by creating a small project with .NET less than 4.5 and converting it to 4.5?
Which versions do you use? If your Isolator is older than 7.5, download 7.5 and let me know if it helps.
Looking forward to your reply.
answered by alex (18k points)
0 votes
Hi Alex,

Thanks for the response.
I'm running the latest version of both Resharper and Typemock. I am able to reproduce this by creating a small project in .NET 4.0 and then converting it to 4.5, however, the issue also appears when simply creating a small project in .NET 4.5.
answered by thni (3.2k points)
0 votes
It reproduces with NUnit (I tried MSTest before).
I'm working on it, I'll keep you posted.
answered by alex (18k points)
0 votes
Ok, to fix this issue open namespaces.dat (in your Isolator install directory) and add the following line: "JetBrains.ReSharper.TaskRunner.CLR45.x64.exe"

Let me know if it helps.
answered by alex (18k points)
0 votes
This fixed the issue! Thanks.
answered by thni (3.2k points)
0 votes
Great :)

It will be fixed in the next version
answered by alex (18k points)
...