chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes

I have an issue that started appearing after an upgrade of V
We are using 
Typemock Isolater 8.9.2
OpenCover 4.7.922
Visual Studio 2019 Build tools

To run our typemock test with OpenCover, we use a command like the following:

TMockRunner.exe OpenCover.Console.Exe -target:vstest.console.exe -register:Path64 -targetArgs:mydlltotest.dll /logger:trx /settings:mySettings.runsettings /InIsolation -output:cover.xml

This worked correctly for us with Visual Studio 2019 Build tools version 16.5.5 (and prior).

This started failing for us when we updated to the latest version of Visual Studio 2019 Build tools (currently 16.8.3):

The tests fail with the following error message:

12:39:27 *** OpenCover Profiler is loaded instead of Typemock Isolator. You can enable Isolator using the following methods:

  * To run Typemock Isolator as part of an automated process you can:
     - run tests via TMockRunner.exe command line tool and use the -link <ProfilerName>
     - use 'TypeMockStart' tasks for MSBuild or NAnt <TypeMockStart Link = <ProfilerName>/>
  For more information consult the documentation (see 'Running Unit Tests in an Automated Build')

Is this a known issue?  Are there any workarounds or fixes available?


Matt Smith

asked by smithmw (610 points)

1 Answer

0 votes

Hi Smith,

I'm sorry to hear about the issue you are experiencing.

This issue is not a know issue, and I tried to reproduce it with no luck.

It seems that Typemock's profile is failed to load.

Can you please check whether you deployed the TmockRunner or not?
To deploy the TmockRunner, go to the CMD and run:
TmockRunner pathTMockRunner.exe -Deploy.
Additonlly, please send us the logs of the run.
To enable the logs, you can check this link on running tests with TmockRunner:
Especially the "-logpath" attribute.
Also, check that the license is set and valid through our Configuration tool.

Please keep me posted.


Alon Sapozhnikov.

answered by Alon_TypeMock (9k points)

I've checked the TypeMock Isolate Configuration tool and it shows the appropriate Company/License Code with Edition "Essential Perpetual" and it is set for "All Users".

I attempted to do what you asked regarding "deploy", but it returned an error.  Here's the output:

C:Program Files (x86)TypemockIsolator8.9BuildScripts>TMockRunner.exe -Deploy

Error in TMockRunner System.IndexOutOfRangeException: Index was outside the bounds of the array.

   at _MR3nDhw3nNPkdZRD6feqA0CwXFM_._6iaWOy9JInRW66AvWVOWwo0t4AH_._GaI2dLwnmOkliwN3PDJm7DXd6iM_(String[] )

   at _MR3nDhw3nNPkdZRD6feqA0CwXFM_._DqZWE1btQAawuxGh3MEQKuNmGoE_._CrcuL1qA7gGiOFK1I2JzgopPGzJ_(String[] )

Reading the documentation it indicates you should specify a path after the deploy argument, so perhaps that is why I get the error.  However, it's not clear to me why this step should be necessary nor what it is accomplishing.  I have Typemock installed locally on the machine.

Next, I'm going to turn on logging and provide the logs after attempting a run


Sorry to hear the issue still exists.

Waiting for the logs.


Alon Sapozhnikov.

Support Specialist.

It appears that this may be due how we were calling this through powershell. It's not clear to me yet, why the behavior changed when moving to a new version of Visual Studio 2019.  

Sorry for the false alarm.  I'll report back if I have additional findings or issues with respect to this.  Thanks for your help.

Hi Smith,

Thank you for keeping us posted.

If you need any more assistance don't hesitate to contact us.


Alon Sapozhnikov.

Support Specialist.