chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
After installing 4.2.1 Visual Studio 2008 the VSTestHost.exe process would crash when running tests, and the test suite would return this error:

"Test host process exited unexpectedly."

This only happens with the 4.2.1 x86 version is installed.

This was happening on 2 of our standard builds at work. To isolate the issue I built a fresh XP x64 box at home and installed VS2008. Tests ran fine, as soon as 4.2.1 x86 was installed I started receiving the error. Once I uninstalled 4.2.1 x86, everything worked fine again.

I also confirmed that everything works fine with 4.2.1 x64 installed, as well as with 4.1.0 (either x86 or x64).
asked by 9810292 (720 points)

9 Answers

0 votes

Thank you for this report.

One of the things that has changed between 2008 and 2005 is the running mode of the application. While the 2005 run n 32Bit mode, the new 2008 is running in 64bit mode (when available). This means that on a 64 bit machines you will need to install the 64 bit version of Typemock Isolator.

In any case, you cans till work in 32bit mode if you like, see here
If you still want to work in 32 bit mode you can install the 32bit version of Typemock Isolator and instruct the IDE to run in 32bit mode see here for further details.
answered by lior (13.2k points)
0 votes
Thanks for the follow. Although I am still a little confused.

So are you saying with Vistual Studio 2008 I only need the x64 version installed? (The website read like I had to have both installed). When I only have the x64 version installed I don't seem able to run TypeMoc. When I run test using TypeMock it tells me to enable it, but the enable button is not available in the tools menu.

When you say 2008 is running in 64-bit mode what do you mean? The DevEnv.exe process on my box still shows it running as a 32-bit process, is there different media for Visual Studio 2008 x64??

I appreciate your assistance, I am just a little confused.


answered by 9810292 (720 points)
0 votes

Sorry for the confusion I'll try to make it clearer.
In order to make things work follow our documentation and install both versions of typemock on a 64 bit machine.

Although installing the 64 bit only should have been enough, currently we have some issues with the 64 bit installer and until we solve them installing the 32bit as well will fix the installation and will allow you to work.(the main problem is that the add-in is not properly installed in the 64bit version so running tests using the IDE fails)

Regarding IDE versions, youll need to remeber that the IDE is not the actual process which runs the tests, that process was running in 32bit mode when spawned by the 2005 IDE, but now using the 2008 IDE is spawned in 64 bit mode.

hope this make things clearer, if not let me know.
answered by lior (13.2k points)
0 votes
Yep, that makes total sense, and that is what we did initially.

But when both versions are installed (specifically the x86 version), we get the error I talk about in the top post.

I tried it on a fresh XP x64 install, only visual studio 2008 team suite was installed. I can run tests just fine (just simple tests, create a class, create a test project for that class). As soon as I installed TypeMock (x86 and x64), I can no longer run tests with the error above (not even using TypeMock code in the tests). If I uninstall the x86 version I can run tests again.

I did try the same test with 4.1.0, and everything works fine.
answered by 9810292 (720 points)
0 votes
ok, now I am confused ;)

Basically what you are telling, is that no matter which variant you install you can't seem to run any of your tests. right?

I also understand that you tried installing everything on a fresh machine and still you couldnt make any of the tests run.

If this is the case I suggest that we take it offline. In order to see what makes it crash we shall need to check the logs for that.
Ill send you an email with details on how to produce the logs.
answered by lior (13.2k points)
0 votes
Sounds good, I am fine with taking it offline.

But just to clarify, if TypeMock 4.2.1 x86 version is installed I can't use Visual Studio Team Suite to run tests through the IDE, whether the tests use TypeMock or not.

I can run them manually using MSTest, but the VS IDE gives an error. I can provide a screenshot offline if you want.

Thanks for your help!
answered by 9810292 (720 points)
0 votes
Hello, I get into the same situation with VS2008 Team System Development Edition (Japanese) and TypeMock Isolator 4.2.2 (both x86 and x64 are installed) on Windows Server 2003 R2 SP2 x64.

The error causes in initializing Microsoft.VisualStudio.TestTools.Diagnostics.EqtTrace class.

The error message is:
[quote]System.TypeInitializationException ‚̓nƒ“ƒhƒ‹‚³‚ê‚Ü‚¹‚ñ‚Å‚µ‚½
answered by mimoriso (140 points)
0 votes

Thanks for the report. As Lior said, the 64 bit changes in VS are probably the cause of this issue. We are investigating it, and will let you know as soon as we find a solution.

answered by gilz (14.5k points)
0 votes
We fixed the problem in version 4.2.3
You can download the version here
answered by ohad (35.4k points)