chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes

I've being working with the Community Edition for a while now and am impressed by its power and usability. Recently I ran into the following problem:

Typemock throws an exception saying that Code Coverage is only supported in the Enterprise Edition. I'm not running the unit tests with coverage, I start the test with TestDriven.Net. My problems did start after I ran NCover, before that the exact same unit tests were running fine.

A couple of unit tests with mocks still work, I cannot see any difference between the working and nonworking unittests

I already tried the following:
Deinstalled 4.2.4 (32-bit version)
Installed 4.3 (32-bit version)

Deinstalled Test Driven.Net
Installed Test Driven.Net

Changed the InProcServer from C:Program FilesTypemockIsolator.3ProfileLinker.dll to NCoverCoverLib.dll => Typemock complains that it needs code coverage.


asked by c_vd_hoeven@hotmail. (680 points)

4 Answers

0 votes
Hi Conrad,

It's good to hear you like Typemock 8)

Regarding the issue you are experiencing: is there any coverage tool linked in the Typemock Isolator Configuration utility?
To check this please start the utility through the start menu or the Visual Studio tools menu. Under the "Profilers/Code Coverage" tab make sure no profiler is linked with Typemock. If there is a coverage tool linked, click the 'Unlink' button and try to run your tests again. Please let me know if this helps.

Typemock Support
answered by doron (17.2k points)
0 votes
Hi Doron,

Thanks for your speedy reply. There is no coverage tool linked in the config utility.

I did scan the TypeMock-ProcesInvocation86.exe.out file and found several references to Microsoft.VisualStudio.Coverage.Init_e670ee364133b8508ed273b71dcfe009 void Register() / *INFO** Visual Studio Coverage Recognized...
and I saw in ProcesExplorer that the Microsoft.VisualStudio.QualityTools.CodeCoverage.dll is loaded in devenv.

Not sure what is going on here, I did run the test with VS coverage once Now I just have to find a way to disable it.

*** Running Typemock Isolator with Code Coverage Tools is an Enterprise feature, to enable please enter a license key."

at TypeMock.MockManager.a(String A_0)
at TypeMock.MockManager.a(String A_0, String A_1, Object A_2, Object A_3, Boolean A_4, Object[] A_5)
at TypeMock.InternalMockManager.getReturn(Object that, String typeName, String methodName, Object methodParameters, Boolean isInjected, Object p1)
answered by c_vd_hoeven@hotmail. (680 points)
0 votes

Since you've already produced logs (the file the excerpt are from), it would be helpful if you send them to us. There should be 2 files created for each run. you can identify the pair by the date and time.

Please send BOTH to our support email: support at typemock dot com.

Thanks in advance,
answered by gilz (14.5k points)
0 votes
VS team coverage creates a number of instrumented pdb files. These files are not removed by a clean build. After manually removing them from the debug directory, it all works again.

Thanks for the support,

answered by c_vd_hoeven@hotmail. (680 points)