chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
I downloaded Isolator++ and activated the license using the activation link. When I try to run unit tests it gives Assert failed. License check failed

Please run Isolator++ Configuration tool.

I ran the tool and entered the activation code from the email there and it seemed to accept it. However I still get license check failure when trying to run the unit test.
I am using MSTest in Visual Studio 2022, but building using 2013 tools.

Thanks,

Mark
closed with the note: Solved by mail.
asked by mark.swaisgood (610 points)
closed by Alon_TypeMock

2 Answers

0 votes

Hi Mark,

We will try to reproduce the issue on our machines and invistigate it.
Meanwhile, I'm sending you a private email in order for you to send me logs and any more info needed.

Best,
Alon Sapozhnikov.
Support Specialist.

answered by Alon_TypeMock (10.4k points)
+1 vote

Issue was sloved by adding the msdia140.dll and symsrv.dll( located at "C://ProgramFiles(x86)/Typemock/Isolator++/bin/x64 or x86/")  to the postbuild events like doing with IsolatorCore.dll.

answered by Alon_TypeMock (10.4k points)
...