chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
Hi darrix,

The behavior you've seen is a current limitation of the runner. This is temporary and it's about to be supported in one of our future versions.
asked by Elisha (12k points)

5 Answers

0 votes
Hi,

I suggest that you'll check if Typemock productivity is enabled.
To do that in VS go to Tools -> Add-in Manager and see if Typemock productivity is enabled.

Please let me know the results.
answered by ohad (35.5k points)
0 votes
Hi,
Strange, in that case I suggest that you'll run Visual Studio with log and send us the results to: support @typemock.com
To run VS with log open the Visual studio 2010 command line:
Start -> programs -> Microsoft visual studio 2010 -> Visual studio tools -> Visual Studio Command Prompt
In the command prompt type: >> devenv /Log
Open a solution with tests and than close it.
You'll find the log file here:
%APPDATA%\Microsoft\VisualStudio\10.0\ActivityLog.xml.

You can find the value of %appdata% on your machine by typing "echo %appdata%" in the command line.
answered by ohad (35.5k points)
0 votes
Hi,

Based on the log it seems like IntelliTest is loaded successfully. Can you please try a simple case - create a new test project and paste the following code into the test file:

[TestClass]
public class UnitTest1
{
    [Isolated]
    [TestMethod]
    public void TestMethod1()
    {
        A a = new A();
        a.Foo();
    }
}

public class A
{
    public void Foo(B b)
    {
        
    }
}

public class B
{
    public int Bar()
    {
        return 0;
    }
}


Then place the carret as in the images:
FullHint.jpg
Or
MiniHint.jpg

Does the hint appears like in the images?

In addition, can you please enable Isolator logs (In VS go to Typemock->Options->Visual Studio->Enable logs). Then restart VS and send post the log file starting with "Typhoon*.log".
answered by Elisha (12k points)
0 votes
Hi,

I see in the log that of Visual Studio that Test-Lint loads into the IDE. It should have shown warnings, for example in the posted screenshot about missing Assert in the test. I'd like to investigate the reason for it, can you post Test-Lint logs? The logs are found in %Temp% folder with the name "TestQuest.sil".
answered by Elisha (12k points)
0 votes
Hi,

This is interesting, perhaps I was wrong regarding Test-Lint being loaded. Is it currently enabled in the extensions manager?
Extensions.jpg
answered by Elisha (12k points)
...