chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I wanted to see what, if any, delay would be when I introduced Typemock to my build process.  I took a branch that did not have any Typemock-ed tests and ran the build.  I tried this several times, and its averaging about 5 mins to run the tests.  When I introduced Typemock (just the TypemockRegister, TypemockStart and TypemockEnd and the related files neccessary to get it building) no additional changes (no new tests), it added 30 mins to the testing time.  Is this expected?   Do you have any tuning suggestions?




After reviewing the logs a bit more, it appears that there are two integration tests (that pre-date our Typemock implementation) that are taking up most of the time.  Even though it is not supposed to be using Typemock, is it possible that Typemock is getting involved somehow?  I can see that before Typemock is introduced, it runs significantly shorter than when Typemock is in the mix.  Is there a way to explicitly tell Typemock to not work with a test?
asked by jim.little (3.6k points)
edited by jim.little

1 Answer

0 votes

This was solved offline.

  • build configuration was fixed
  • blacklist.dat implemented correctly
  • AutoDeploy was used correctly
answered by eli (5.7k points)