chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
I have installed TypeMockSetup352.msi, but the add-in does not show in Visual Studio. I have admin rights and the only way to run the tests is using tmockrunner from the commandline. Even running the mocking_on.bat file has no affect.

I can see it has installed to "C:Documents and SettingsAll UsersApplication DataMicrosoftVisualStudio8.0Addins". Is there somewhere else it needs to be as my add-in works fine but isn't at the above location (Maybe there is another way)???

My ideal situation would be to be able to run all tests from the add-in (Right-click > RunTests) while using typemock.

I really like the fact you can mock classes and not just interfaces. We have a lot of legacy code so it fits perfectly, but I dont want to run nunit gui or any command line tool as we want testing to be as seamless as possible and have quite a few projects

Any help?

asked by lancej (1k points)

20 Answers

0 votes
All it was was the Monitor.TryEnter(..), I wanted to mock it so I can test what happens when the lock failed.
I just created a little wrapper class so it wasn't a hard workaround.

I suppose any classes that go outside the test envelope will need to be mocked, like IO and Networking etc. I suspect these are not part of the core lib, but any that do that sort of thing will need to be mocked.

Gut feeling is something we have setup/configured that is doing it.

Config is...

Microsoft Visual Studio 2005
Version 8.0.50727.42 (RTM.050727-4200)
Microsoft .NET Framework
Version 2.0.50727

Installed Edition: Professional

Microsoft Visual Basic 2005 77626-009-0000007-41034
Microsoft Visual Basic 2005

Microsoft Visual C# 2005 77626-009-0000007-41034
Microsoft Visual C# 2005

Microsoft Visual C++ 2005 77626-009-0000007-41034
Microsoft Visual C++ 2005

Microsoft Visual J# 2005 77626-009-0000007-41034
Microsoft Visual J# 2005

Microsoft Visual Web Developer 2005 77626-009-0000007-41034
Microsoft Visual Web Developer 2005

Crystal Reports AAC60-G0CSA4B-V7000AY
Crystal Reports for Visual Studio 2005

TestDriven.NET 2.0.1761 Personal
For more information, see the TestDriven.NET website at Development by Jamie Cansdale <>. Copyright (c) 2002-2006 Mutant Design.
answered by lancej (1k points)
0 votes
Could you please check add-in security:
Tools->Options->Environment->Add-in/Macro Security
Make sure that Allow Add-in Componenets to Load is checked.
answered by scott (32k points)
0 votes
Those are all checked,

I did do a filemon, where I can see VS2005 is reading the .addin, but it is not touching the dll (renaming or deleting doesn't cause an error).


answered by lancej (1k points)
0 votes
I didn't really want to reach to this stage but from what I read either this will work.
> devenv.exe /ResetSettings
you will need to reinstall Visual Studio.
answered by scott (32k points)
0 votes
I think that this could be related to a bug in VS 2005. I initially had this same problem when trying to use GhostDoc and now I see the same thing when trying to install TypeMock. I found the same issue discussed at this GhostDoc Forum Topic. If you read the post he mentions that there is a bug and it should be fixed in the VS 2005 SP1 update.
answered by idavis (140 points)
0 votes
I have just installed the SP1 patch and it still hasn't fixed it.
answered by lancej (1k points)
0 votes
Do other plugins work?
Please reset the Visual Studio/Reinstall TypeMock,
if this doesn't work we will take this offline.
answered by scott (32k points)
0 votes
No, The only add-ins that are visible are com registered ones like All xml registered add-in do not work appear including TypeMock. Unless I can get a com registered version of TypeMock, I will either have to try reinstallatting VS or just live with it.

answered by lancej (1k points)
0 votes
TestDriven now has a Test with TypeMock.
As TestDriven still uses the registry you will be able to use it.
In any event, I would strongly suggest to reinstall V.S.
answered by scott (32k points)
0 votes
Out of the blue, I seemed to have solved it.

I installed .net3.0 RC1.

For some bizzare reason this fixes it.

answered by lancej (1k points)