chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
Welcome to Typemock Community! Here you can ask and receive answers from other community members. If you liked or disliked an answer or thread: react with an up- or downvote.
0 votes
Hi,

Once upgrading to VS2012 and reading the forum I also installed the latest version on TypeMock (7.0.9). Unfortunately I am faced with the below output from TypeMock when attempting to run all tests. I thought that this latest version worked with VS2012? I have yet to see anyone with success running TypeMock-dependent unit tests in VS2012:

Failed killing daemon: System.ComponentModel.Win32Exception (0x80004005): Access is denied
at System.Diagnostics.Process.Kill()
at Typemock.Common.Core.DaemonNUnitRunner.KillDaemon(Process process)
State error: leftover daemon 4500
Killing daemon
Failed killing daemon: System.ComponentModel.Win32Exception (0x80004005): Access is denied
at System.Diagnostics.Process.Kill()
at Typemock.Common.Core.DaemonNUnitRunner.KillDaemon(Process process)
Failed killing daemon: System.ComponentModel.Win32Exception (0x80004005): Access is denied
at System.Diagnostics.Process.Kill()
at Typemock.Common.Core.DaemonNUnitRunner.KillDaemon(Process process)
State error: leftover daemon 6072
Killing daemon
Failed killing daemon: System.ComponentModel.Win32Exception (0x80004005): Access is denied
at System.Diagnostics.Process.Kill()
at Typemock.Common.Core.DaemonNUnitRunner.KillDaemon(Process process)
Test run failed more than 1 times - aborting
Test run failed more than 1 times - aborting
System.ServiceModel.CommunicationException: There was an error reading from the pipe: Unrecognized error 109 (0x6d). ---> System.IO.PipeException: There was an error reading from the pipe: Unrecognized error 109 (0x6d).
at System.ServiceModel.Channels.PipeConnection.FinishSyncRead(Boolean traceExceptionsAsErrors)
at System.ServiceModel.Channels.PipeConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
--- End of inner exception stack trace ---

Server stack trace:
at System.ServiceModel.Channels.PipeConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
at System.ServiceModel.Channels.DelegatingConnection.Read(Byte[] buffer, Int32 offset, Int32 size, TimeSpan timeout)
at System.ServiceModel.Channels.SessionConnectionReader.Receive(TimeSpan timeout)
at System.ServiceModel.Channels.SynchronizedMessageSource.Receive(TimeSpan timeout)
at System.ServiceModel.Channels.TransportDuplexSessionChannel.Receive(TimeSpan timeout)
at System.ServiceModel.Channels.TransportDuplexSessionChannel.TryReceive(TimeSpan timeout, Message& message)
at System.ServiceModel.Dispatcher.DuplexChannelBinder.Request(Message message, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannel.Call(String action, Boolean oneway, ProxyOperationRuntime operation, Object[] ins, Object[] outs, TimeSpan timeout)
at System.ServiceModel.Channels.ServiceChannelProxy.InvokeService(IMethodCallMessage methodCall, ProxyOperationRuntime operation)
at System.ServiceModel.Channels.ServiceChannelProxy.Invoke(IMessage message)

Exception rethrown at [0]:
at System.Runtime.Remoting.Proxies.RealProxy.HandleReturnMessage(IMessage reqMsg, IMessage retMsg)
at System.Runtime.Remoting.Proxies.RealProxy.PrivateInvoke(MessageData& msgData, Int32 type)
at Typemock.Common.Core.ITestRunnerService.RunTests(List`1 assemblies, List`1 testNames, String sessionID, Dictionary`2 testsOptions)
at Typemock.Common.Core.TestRunnerServiceSynched.RunTests(List`1 assemblies, List`1 testNames, String sessionID, Dictionary`2 testsOptions)
at Typemock.Common.Core.DaemonNUnitRunner.PerformRunTests(List`1 testsAssemblies, IEnumerable`1 testNames, Guid sessionGuid, Dictionary`2 testOptions)
at Typemock.Common.Core.DaemonNUnitRunner.<>c__DisplayClass5.<TryRunTests>b__0()

Test run results -
unexpected error when trying to run test: <this line repeats for each and every unit test within my solution>
asked by (2.4k points)

6 Answers

0 votes
Hi Slavo,

We had some issues with VS12 and made a patch that should solve most of them.

Please download and install it from the following link:

https://www.typemock.com/files/patches/T ... ndVS12.msi

Please let me know if it helps.
answered by (18k points)
0 votes
Hello,

I have installed the patch but unfortunately there is no change to the result of attempting to run all of our unit tests.

I have not included the duplicate stacktrace as this won't help you. If there is anything else I can provide, please do not hesitate to ask.

I also notice, which may be a red herring, that your filename includes "WIN8". I am currently running Windows 7, it installed fine but fails as per above.

Regards,

John
answered by (2.4k points)
0 votes
Hello,

Can you confirm if this is being investigated?

Regards,

John
answered by (2.4k points)
0 votes
Hi Slavo,

Thank you for the reply. The installer has win8 modifications but should run on any windows version.
We are investigating this issue and I will update you on any change.

Also, If you notice anything else that might be related to this issue please post it here.
answered by (18k points)
0 votes
Hi Slavo,

Both the original issue and the win8 installation issue were handled in v 7.1.2.

Please let me know if it helps.
answered by (18k points)
0 votes
Hi Alex,

We are now fully able to run our unit tests. This was achieved by removing all private accessor's and disabling Typemock Test Lint / Typemock Smart-Runner.

We have now upgraded to Isolator 7.1.2 and are able to reactivate Smart-Runner.

However, we have some failing unit tests that did not fail in previous versions of Typemock. I shall raise this as a separate issue so that you may clear this one.

Many thanks,

John
answered by (2.4k points)
...