chevron-thin-right chevron-thin-left brand cancel-circle search youtube-icon google-plus-icon linkedin-icon facebook-icon twitter-icon toolbox download check linkedin phone twitter-old google-plus facebook profile-male chat calendar profile-male
0 votes
Hi, i'm evaluating the version of 7.4 for c#.However ,i meet some problems , could anyone explain?
Typemock7.4.0.0 for c#
issue1: all test methods do not work
step1: install typemock
step2: Open my solution on VS2012
step3: Write some test methods with typemock. Here all can be run.
step4: on vs2012, typemock->Fix Reference->Copy dlls and Reference them->OK
step5: test methods could not be run whatever i restart VS or recompile project or reboot OS. All error messages are 'can't find test xxxx '. I also tried to establish new UT project and get the same error.
Solution: uninstall and reinstall typemock.

issue2: shields are gone.
step1: install typemock
step2: Open my solution with VS2012
step3: write some test methos with typemock. Here all test methods are with green shields
step4: Be off work and sleep(have a lunch). When i come back, all shields are gone.Whatever i restart/recompile/reboot , same phenomenon.
Solution: don't know

issue3: must call CallOriginal()
step1: install typemock
step2: Open my solution with VS2012
step3: write some test methos with typemock and all settings are default. Adding a line of [assembly:(isolated,DesignMode.Programtic)] at the head of the namespace.
When i want to verify a private function is called, the result is failed. Isolate.Verify.Nonpublic.wascalled(myobject,"PrivateMethod");
Add a line of Isolate.Nonpublic.Whencalled(myobject,"PrivateMethod").callOriginall();
then the result is passed.

asked by marcusmh (2.1k points)

1 Answer

0 votes

Please review my answer via email.
answered by NofarC (4k points)